<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8" />
<title>A Group of Democrats led by Jewish congressman Steve Cohen Just Officially Moved to Impeach Donald Trump as President | The Ugly Truth</title>
<link rel="pingback" href="https://theuglytruth.wordpress.com/xmlrpc.php" />
<link rel="profile" href="http://gmpg.org/xfn/11" />

<!--[if IE]>
<style type="text/css">
	#page-wrap1 {
		background: url(https://s0.wp.com/wp-content/themes/pub/fusion/images/header-bg.png) repeat-x;
	}
</style>
<![endif]-->

<!--[if lte IE 6]>
<script type="text/javascript">
/* <![CDATA[ */
	blankimgpath = 'https://s0.wp.com/wp-content/themes/pub/fusion/images/blank.gif';
/* ]]> */
</script>
<![endif]-->

<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="The Ugly Truth &raquo; Feed" href="https://theuglytruth.wordpress.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Ugly Truth &raquo; Comments Feed" href="https://theuglytruth.wordpress.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Ugly Truth &raquo; A Group of Democrats led by Jewish congressman Steve Cohen Just Officially Moved to Impeach Donald Trump as&nbsp;President Comments Feed" href="https://theuglytruth.wordpress.com/2017/11/17/a-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1505864856h&ver=4.9-20171117"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s1.wp.com/_static/??-eJx9kNEOgjAMRX/IuZAo4oPxW2BUGKxbQ7sgf+8QfUGzl6W3OSdtp2dSJngBLxqjIhc761nPZAIqRutg2aWjYT7o/5qzI7AeQKg2o3qnHD6BqwVaRYFll3KaCROkPlItK4HQ2hocYMJy2mzbDtKchHxqJfDMKkjld9Ba9umq7GbbRzUNTcCs0os2opI+7fbrbW1NsdGPyDZ4zbI4WLk73orTtawuRXUuhhdax52g' type='text/css' media='all' />
<!--[if lte IE 6]>
<link rel='stylesheet' id='fusion-ie6-css'  href='https://s0.wp.com/wp-content/themes/pub/fusion/ie6.css?m=1282587368h&#038;ver=4.9-20171117' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='all-css-2-1' href='https://s1.wp.com/_static/??-eJyNj9EKwjAMRX/IGKqC+iB+y6xZjbRNWVKGf2/nEObL8O0ecs+F4FjASzbKhvagRIql3rCvypKRs0e1VyQYi5e09aobXBipQok1cFYc+R7IFE0KFNGWPuI/iornLgK3yi/MMmMWm4/fsLYaSCCK72x6YAnQx46HNXWgW5TQYsDWWuAkXdPFHc7H3cm5vXu+AXZcdLo=' type='text/css' media='all' />
<link rel='stylesheet' id='print-css-3-1' href='https://s0.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h' type='text/css' media='print' />
<link rel='stylesheet' id='all-css-4-1' href='https://s2.wp.com/_static/??-eJx9i9EKwjAMRX/IGoVN54P4LVnp2kialCbD3xcfRGTi0z0XzoFHC1HFkzjUNTReM4kBRieVGfuH9tFsB7/1puZhYaQOVrCT5Pf+q0wjIQfWrN9nE3lJNRmUATLrjPwSbvV6HC6H83Qap/H+BMWZScE=' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyFj90KwjAMhV/IrAw6xQvxWWoXS2r/bNoNfXo70At1KARCTr4cTsScgIJ2dUQWttW1Yr49W2d5I34B4MlkVbDzFF6wjqFgKAvr44kcQmXMyjStGZ3jCpciF4/MDVrZvkeiMBHOfzGLJSl9gYxM9y9XXyG5aiiwyOjaAyMsGT6mdnX0h17uh36Qcre1DyuucHk='></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1377793621h' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://theuglytruth.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Trump’s Mideast Plan Is Bad for&nbsp;Israel' href='https://theuglytruth.wordpress.com/2017/11/17/trumps-mideast-plan-is-bad-for-israel/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://theuglytruth.wordpress.com/2017/11/17/a-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president/" />
<link rel='shortlink' href='https://wp.me/p2dGk-LG9' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Ftheuglytruth.wordpress.com%2F2017%2F11%2F17%2Fa-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Ftheuglytruth.wordpress.com%2F2017%2F11%2F17%2Fa-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="A Group of Democrats led by Jewish congressman Steve Cohen Just Officially Moved to Impeach Donald Trump as President" />
<meta property="og:url" content="https://theuglytruth.wordpress.com/2017/11/17/a-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president/" />
<meta property="og:description" content="Articles of Impeachment introduced by Jewish Congressman Steve Cohen who is quoted saying&#8211; &#8216;We have taken this action because of great concerns for the country and our Constitution and …" />
<meta property="article:published_time" content="2017-11-18T01:06:58+00:00" />
<meta property="article:modified_time" content="2017-11-18T01:06:58+00:00" />
<meta property="og:site_name" content="The Ugly Truth" />
<meta property="og:image" content="http://img.youtube.com/vi/ZukeUMa3WXo/0.jpg" />
<meta property="og:image:secure_url" content="https://img.youtube.com/vi/ZukeUMa3WXo/0.jpg" />
<meta property="og:locale" content="en_US" />
<meta property="og:video:type" content="text/html" />
<meta property="og:video" content="http://www.youtube.com/embed/ZukeUMa3WXo" />
<meta property="og:video:secure_url" content="https://www.youtube.com/embed/ZukeUMa3WXo" />
<meta name="twitter:site" content="@tut83809" />
<meta name="twitter:text:title" content="A Group of Democrats led by Jewish congressman Steve Cohen Just Officially Moved to Impeach Donald Trump as&nbsp;President" />
<meta name="twitter:image:src" content="http://img.youtube.com/vi/ZukeUMa3WXo/0.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@tut83809" />
<meta property="fb:app_id" content="249643311490" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />
<link rel="shortcut icon" type="image/x-icon" href="https://s2.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="icon" type="image/x-icon" href="https://s2.wp.com/i/favicon.ico" sizes="16x16 24x24 32x32 48x48" />
<link rel="apple-touch-icon-precomposed" href="https://s0.wp.com/i/webclip.png" />
<link rel='openid.server' href='https://theuglytruth.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://theuglytruth.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://theuglytruth.wordpress.com/osd.xml" title="The Ugly Truth" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<meta name="application-name" content="The Ugly Truth" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="Intelligent &#039;anti-Semitism&#039; for thinking Gentiles" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://theuglytruth.wordpress.com/feed/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="title" content="A Group of Democrats led by Jewish congressman Steve Cohen Just Officially Moved to Impeach Donald Trump as&nbsp;President | The Ugly Truth on WordPress.com" />
<meta name="description" content="Articles of Impeachment introduced by Jewish Congressman Steve Cohen who is quoted saying-- &#039;We have taken this action because of great concerns for the country and our Constitution and our national security and our democracy&#039; Time.com A half-dozen Democrats on Wednesday introduced articles of impeachment against President Donald Trump, accusing him of obstruction of justice&hellip;" />
	<style type="text/css">
						#header h1 a {
					color: #ffffff !important;
				}
			</style>
<link rel="amphtml" href="https://theuglytruth.wordpress.com/2017/11/17/a-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president/amp/" /><style type="text/css" id="syntaxhighlighteranchor"></style>
</head>
<body class="post-template-default single single-post postid-183281 single-format-standard mp6 customizer-styles-applied two-column content-sidebar fixed highlander-enabled highlander-light">

<div id="page-wrap1">

<div id="page-wrap2">

	<!-- page (actual site content, custom width) -->
	<div id="page">

	<div id="main-wrap">

		<div id="mid-wrap">

		<div id="side-wrap">

			<!-- mid column -->
			<div id="mid">

				<div id="header">

				<div id="topnav" class="description"> Intelligent &#039;anti-Semitism&#039; for thinking Gentiles</div>

				<h1 id="title"><a href="https://theuglytruth.wordpress.com">The Ugly Truth</a></h1>

					<div id="tabs">
						<div class="menu"><ul>
<li ><a href="https://theuglytruth.wordpress.com/">Home</a></li></ul></div>
					</div>

				</div>
	<div id="mid-content">

	
		<div class="navigation">
			<div class="alignleft">&laquo; <a href="https://theuglytruth.wordpress.com/2017/11/17/trumps-mideast-plan-is-bad-for-israel/" rel="prev">Trump’s Mideast Plan Is Bad for&nbsp;Israel</a></div>
			<div class="alignright"></div>

			<div class="clear"></div>
		</div>

		<div id="post-183281" class="post-183281 post type-post status-publish format-standard hentry category-uncategorized">

			<h2 class="title">A Group of Democrats led by Jewish congressman Steve Cohen Just Officially Moved to Impeach Donald Trump as&nbsp;President</h2>

			<div class="entry">
				<div class="postbody entry clearfix">
					<div class="pd-rating" id="pd_rating_holder_2452776_post_183281"></div><br/><h2><a href="https://theuglytruth.wordpress.com/2016/12/14/adl-major-jewish-groups-snub-invite-to-trump-hotel-hanukkah-party-in-dc/trump3-3/" rel="attachment wp-att-163407"><img data-attachment-id="163407" data-permalink="https://theuglytruth.wordpress.com/2016/12/14/adl-major-jewish-groups-snub-invite-to-trump-hotel-hanukkah-party-in-dc/trump3-3/" data-orig-file="https://theuglytruth.files.wordpress.com/2016/12/trump31.jpg?w=620&#038;h=413" data-orig-size="4632,3088" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="trump3" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2016/12/trump31.jpg?w=620&#038;h=413?w=300" data-large-file="https://theuglytruth.files.wordpress.com/2016/12/trump31.jpg?w=620&#038;h=413?w=620" class="alignnone size-full wp-image-163407" src="https://theuglytruth.files.wordpress.com/2016/12/trump31.jpg?w=620&#038;h=413" alt="" width="620" height="413" srcset="https://theuglytruth.files.wordpress.com/2016/12/trump31.jpg?w=620&amp;h=413 620w, https://theuglytruth.files.wordpress.com/2016/12/trump31.jpg?w=1240&amp;h=826 1240w, https://theuglytruth.files.wordpress.com/2016/12/trump31.jpg?w=150&amp;h=100 150w, https://theuglytruth.files.wordpress.com/2016/12/trump31.jpg?w=300&amp;h=200 300w, https://theuglytruth.files.wordpress.com/2016/12/trump31.jpg?w=768&amp;h=512 768w, https://theuglytruth.files.wordpress.com/2016/12/trump31.jpg?w=1024&amp;h=683 1024w" sizes="(max-width: 620px) 100vw, 620px" /></a></h2>
<h2 style="text-align:justify;"><span style="color:#000000;">Articles of Impeachment introduced by Jewish Congressman Steve Cohen who is quoted saying&#8211; &#8216;We have taken this action because of great concerns for the country and our Constitution and our national security and our democracy&#8217;</span></h2>
<p><span id="more-183281"></span></p>
<h3 style="text-align:justify;"><span style="color:#000000;"><a style="color:#000000;" href="http://time.com/5026052/democrats-impeach-donald-trump/">Time.com</a></span></h3>
<h3 style="text-align:justify;"><span style="color:#000000;">A half-dozen Democrats on Wednesday introduced articles of impeachment against President Donald Trump, accusing him of obstruction of justice and other offenses, in a long-shot effort that stands little chance in the Republican-led House.</span></h3>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='620' height='379' src='https://www.youtube.com/embed/ZukeUMa3WXo?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<h3 style="text-align:justify;"><span style="color:#000000;">Indeed, the large majority of Democrats seem intent on having nothing to do with the effort either as lawmakers await the results of special counsel Robert Mueller’s investigation into ties between the Trump campaign and Russia. Democratic leaders have argued that the impeachment campaign riles up Trump’s GOP base, a critical bloc in next year’s midterm elections.</span></h3>
<h3 style="text-align:justify;"><span style="color:#000000;">The five articles accused the president of obstruction of justice related to the FBI investigation into Russian meddling in the 2016 election, undermining the independence of the federal judiciary and other offenses.</span></h3>
<p><img src="https://d229l5sflpl9cp.cloudfront.net/canphoto/24340_lg.jpg" alt="Image result for steve cohen" /></p>
<h3 style="text-align:justify;"><span style="color:#000000;">“We have taken this action because of great concerns for the country and our Constitution and our national security and our democracy,” Rep. Steve Cohen, D-Tenn., said at a news conference to announce the effort.</span></h3>
<h3 style="text-align:justify;"><span style="color:#000000;">Cohen said he understands that Republicans hold the majority in the House and are unlikely to allow hearings on the impeachment articles. He said the group will hold occasional briefings to explain each of the five articles of impeachment and where they believe Trump ran afoul of the law or committed misdeeds that warrant impeachment.</span></h3>
<h3 style="text-align:justify;"><span style="color:#000000;">The obstruction of justice allegation stems from Trump’s firing of FBI Director James Comey, which the lawmakers say was designed to delay and impede an investigation.</span></h3>
<h3 style="text-align:justify;"><span style="color:#000000;">The articles of impeachment also charge that Trump has accepted without the consent of Congress emoluments from foreign states and from the U.S. government. Finally, the articles of impeachment allege he has undermined the federal judiciary and the freedom of the press.</span></h3>
<h3 style="text-align:justify;"><span style="color:#000000;">Cohen and other leaders of the impeachment effort disagreed that their effort could hurt Democrats in next year’s congressional elections.</span></h3>
<h3 style="text-align:justify;"><span style="color:#000000;">“I think the Democratic base needs to be activated. The Democratic base needs to know there are members of Congress willing to stand up against this president,” Cohen said.</span></h3>
<h3 style="text-align:justify;"><span style="color:#000000;">Other lawmakers who have signed onto to the resolution are Democratic Reps. Luis Gutierrez of Illinois, Al Green of Texas, Marcia Fudge of Ohio, Adriano Espaillat of New York and John Yarmuth of Kentucky.</span></h3>
<h3 style="text-align:justify;"><span style="color:#000000;">Gutierrez said he wasn’t afraid to support the resolution despite the concerns of some fellow Democrats.</span></h3>
<h3 style="text-align:justify;"><span style="color:#000000;">“I see a crime and I have a responsibility to dial 911 immediately. I don’t call and try to reach my consensus with all my neighbors and all my friends and those whose opinion I might seek out,” Gutierrez said.</span></h3>
<h3 style="text-align:justify;"><span style="color:#000000;">A spokesman for the Republican National Committee criticized the effort.</span></h3>
<h3 style="text-align:justify;"><span style="color:#000000;">“House Democrats lack a positive message and are completely unwilling to work across the aisle, so instead they’ve decided to support a baseless radical effort that the vast majority of Americans disagree with,” said spokesman Michael Ahrens.</span></h3>
<div id="jp-post-flair" class="sharedaddy sd-rating-enabled sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-183281" class="share-facebook sd-button share-icon" href="https://theuglytruth.wordpress.com/2017/11/17/a-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president/?share=facebook" target="_blank" title="Share on Facebook"><span>Facebook</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon" href="https://theuglytruth.wordpress.com/2017/11/17/a-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president/?share=email" target="_blank" title="Click to email"><span>Email</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-183281" class="share-google-plus-1 sd-button share-icon" href="https://theuglytruth.wordpress.com/2017/11/17/a-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span>Google</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-183281" class="share-twitter sd-button share-icon" href="https://theuglytruth.wordpress.com/2017/11/17/a-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li><a href="#" class="sharing-anchor sd-button share-more"><span>More</span></a></li><li class="share-end"></li></ul><div class="sharing-hidden"><div class="inner" style="display: none;"><ul><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon" href="https://theuglytruth.wordpress.com/2017/11/17/a-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span>Tumblr</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon" href="https://theuglytruth.wordpress.com/2017/11/17/a-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-183281" class="share-pinterest sd-button share-icon" href="https://theuglytruth.wordpress.com/2017/11/17/a-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-183281" class="share-linkedin sd-button share-icon" href="https://theuglytruth.wordpress.com/2017/11/17/a-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-end"></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon" href="https://theuglytruth.wordpress.com/2017/11/17/a-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president/?share=reddit" target="_blank" title="Click to share on Reddit"><span>Reddit</span></a></li><li class="share-end"></li></ul></div></div></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-529252-183281-5a0f8c4c19344' data-src='//widgets.wp.com/likes/#blog_id=529252&amp;post_id=183281&amp;origin=theuglytruth.wordpress.com&amp;obj_id=529252-183281-5a0f8c4c19344' data-name='like-post-frame-529252-183281-5a0f8c4c19344'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>				</div>

					
					
				<p class="postmetadata alt">

					<small>
					This entry was posted on 11/17/2017, 9:34 and is filed under <a href="https://theuglytruth.wordpress.com/category/uncategorized/" rel="category tag">Uncategorized</a>. You can follow any responses to this entry through <a href="https://theuglytruth.wordpress.com/2017/11/17/a-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president/feed/" title="RSS 2.0">RSS 2.0</a>.
					
					You can skip to the end and leave a response. Pinging is currently not allowed.
					
										</small>

				</p>

			</div>

		</div>

	
<div id="post-extra-content">

	<ul class="secondary-tabs">
		<li><a href="#comments"><span><span>Comments (0)</span></span></a></li>
			</ul>

	<div id="commentlist">
		<ol id="comments">

		
			
				<li>Leave a comment</li>

			
		
		</ol>

		
		<div class="commentnavi">
			<div class="commentpager">
							</div>
		</div>

			<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/11/17/a-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://theuglytruth.wordpress.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="52d7feeba2" /><input type="hidden" name="_wp_http_referer" value="/2017/11/17/a-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">

	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" title="Guest">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" title="WordPress.com">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" title="Twitter">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" title="Facebook">
					<span></span>
				</a>
			</li>
			<li>
			<iframe id="googleplus-sign-in" name="googleplus-sign-in" src="https://public-api.wordpress.com/connect/?googleplus-sign-in=https%3A%2F%2Ftheuglytruth.wordpress.com" width="24" height="24" scrolling="no" allowtransparency="true" seamless="seamless" frameborder="0"></iframe>
			</li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
	
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
				<p class="comment-form-posting-as pa-wordpress"><strong></strong> You are commenting using your WordPress.com account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
				<p class="comment-form-posting-as pa-twitter"><strong></strong> You are commenting using your Twitter account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
				<p class="comment-form-posting-as pa-facebook"><strong></strong> You are commenting using your Facebook account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="" alt="Google+ photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
				<p class="comment-form-posting-as pa-googleplus"><strong></strong> You are commenting using your Google+ account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='183281' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="5c4832d91d" /></p>
<input type="hidden" name="genseq" value="1510968396" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="15"/></p>			</form>
			</div><!-- #respond -->
	<div style="clear: both"></div>
	</div>

</div>

	
	</div>
	<!-- mid content -->

</div>
<!-- /mid -->


<div id="sidebar">

	<div id="sidebar-wrap1">

	<div id="sidebar-wrap2">
	
		<ul id="sidelist">
			
				<li><div id="blog_subscription-4" class="widget widget_blog_subscription"><h2 class="title"><label for="subscribe-field">Email Subscription</label></h2>
				<form action="https://subscribe.wordpress.com" method="post" accept-charset="utf-8" id="subscribe-blog">
											<p>Enter your email address to subscribe to this blog and receive notifications of new posts by email.</p>
<p>Join 5,827 other followers</p>
						<p><input type="text" name="email" style="width: 95%; padding: 1px 2px" placeholder="Enter your email address" value="" id="subscribe-field"/></p>
					
					<p>
						<input type="hidden" name="action" value="subscribe"/>
						<input type="hidden" name="blog_id" value="529252"/>
						<input type="hidden" name="source" value="https://theuglytruth.wordpress.com/2017/11/17/a-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president/"/>
						<input type="hidden" name="sub-type" value="widget"/>
						<input type="hidden" name="redirect_fragment" value="blog_subscription-4" />
						<input type="hidden" id="_wpnonce" name="_wpnonce" value="cfbacadfde" />						<input type="submit" value="Sign me up!" />
					</p>
				</form>
			
</div></li><li><div id="search-3" class="widget widget_search"><h2 class="title">search TUT</h2>
<form method="get" id="searchform" action="https://theuglytruth.wordpress.com/">
	<input type="text" name="s" size="40" id="searchbox" class="searchfield" />
	<input type="submit" value="Search" class="searchbutton" />
</form></div></li><li><div id="blog-stats-3" class="widget widget_blog-stats"><h2 class="title">Blog Stats</h2>		<ul>
			<li>18,210,177 hits</li>
		</ul>
		</div></li><li><div id="media_image-13" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="https://theuglytruth.files.wordpress.com/2014/12/uncle-sam-is-israels-bitch-3.jpg" class="" rel="" target=""><img class="image alignnone" src="https://theuglytruth.files.wordpress.com/2011/12/unclesam1.jpg?w=50" alt="" width="200" height="300" /></a></div></li><li><div id="media_image-38" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><div style="max-width: 210px" class="wp-caption alignnone"><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=FH6JY92B97KKQ" class="" rel="" target=""><img width="200" height="50" src="https://theuglytruth.files.wordpress.com/2016/02/subscribe2.png?w=200" class="image wp-image-114962 alignnone attachment-200x100 size-200x100" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2016/02/subscribe2.png?w=200 200w, https://theuglytruth.files.wordpress.com/2016/02/subscribe2.png?w=400 400w, https://theuglytruth.files.wordpress.com/2016/02/subscribe2.png?w=150 150w, https://theuglytruth.files.wordpress.com/2016/02/subscribe2.png?w=300 300w" sizes="(max-width: 200px) 100vw, 200px" data-attachment-id="114962" data-permalink="https://theuglytruth.wordpress.com/subscribe2/" data-orig-file="https://theuglytruth.files.wordpress.com/2016/02/subscribe2.png" data-orig-size="800,200" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="subscribe2" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2016/02/subscribe2.png?w=300" data-large-file="https://theuglytruth.files.wordpress.com/2016/02/subscribe2.png?w=620" /></a><p class="wp-caption-text">Subscriptions to TUT Radio Network</p></div></div></li><li><div id="media_image-24" class="widget widget_media_image"><h2 class="title">Thank you for helping us keep the lights on</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&#038;hosted_button_id=YJMABNWPQPG4L" class="" rel="" target=""><img width="138" height="50" src="https://theuglytruth.files.wordpress.com/2012/02/paypal2.jpg?w=138" class="image wp-image-35797 alignnone attachment-200x50 size-200x50" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/02/paypal2.jpg?w=138 138w, https://theuglytruth.files.wordpress.com/2012/02/paypal2.jpg?w=150 150w, https://theuglytruth.files.wordpress.com/2012/02/paypal2.jpg 187w" sizes="(max-width: 138px) 100vw, 138px" data-attachment-id="35797" data-permalink="https://theuglytruth.wordpress.com/paypal2/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/02/paypal2.jpg" data-orig-size="187,68" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="paypal2" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/02/paypal2.jpg?w=187" data-large-file="https://theuglytruth.files.wordpress.com/2012/02/paypal2.jpg?w=187" /></a></div></li><li><div id="media_image-43" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><div style="max-width: 210px" class="wp-caption alignnone"><a href="https://theuglytruth.wordpress.com/category/podbean-archives/" class="" rel="" target=""><img width="200" height="200" src="https://theuglytruth.files.wordpress.com/2014/04/podbean.jpg?w=200" class="image wp-image-65265 alignnone attachment-200x200 size-200x200" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2014/04/podbean.jpg?w=200 200w, https://theuglytruth.files.wordpress.com/2014/04/podbean.jpg?w=400 400w, https://theuglytruth.files.wordpress.com/2014/04/podbean.jpg?w=150 150w, https://theuglytruth.files.wordpress.com/2014/04/podbean.jpg?w=300 300w" sizes="(max-width: 200px) 100vw, 200px" data-attachment-id="65265" data-permalink="https://theuglytruth.wordpress.com/podbean/" data-orig-file="https://theuglytruth.files.wordpress.com/2014/04/podbean.jpg" data-orig-size="800,800" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="podbean" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2014/04/podbean.jpg?w=300" data-large-file="https://theuglytruth.files.wordpress.com/2014/04/podbean.jpg?w=620" /></a><p class="wp-caption-text">ARCHIVED PROGRAMS</p></div></div></li><li><div id="media_image-32" class="widget widget_media_image"><h2 class="title">Anti Semite? Moi?</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.youtube.com/watch?feature=player_embedded&#038;v=l_VzxIVOKbs" class="" rel="" target=""><img width="200" height="172" src="https://theuglytruth.files.wordpress.com/2012/02/latuff_anti_semitism.jpg?w=200" class="image wp-image-36097 alignnone attachment-200x200 size-200x200" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/02/latuff_anti_semitism.jpg?w=200 200w, https://theuglytruth.files.wordpress.com/2012/02/latuff_anti_semitism.jpg?w=400 400w, https://theuglytruth.files.wordpress.com/2012/02/latuff_anti_semitism.jpg?w=150 150w, https://theuglytruth.files.wordpress.com/2012/02/latuff_anti_semitism.jpg?w=300 300w" sizes="(max-width: 200px) 100vw, 200px" data-attachment-id="36097" data-permalink="https://theuglytruth.wordpress.com/latuff_anti_semitism/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/02/latuff_anti_semitism.jpg" data-orig-size="580,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="latuff_anti_semitism" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/02/latuff_anti_semitism.jpg?w=300" data-large-file="https://theuglytruth.files.wordpress.com/2012/02/latuff_anti_semitism.jpg?w=580" /></a></div></li><li><div id="media_image-72" class="widget widget_media_image"><h2 class="title">When Israel Is Mighty</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.youtube.com/watch?feature=player_embedded&#038;v=YSy6ENVAJlY" class="" rel="" target=""><img width="300" height="180" src="https://theuglytruth.files.wordpress.com/2013/06/palchild.jpg?w=300" class="image wp-image-56542 alignnone attachment-300x276 size-300x276" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2013/06/palchild.jpg?w=300 300w, https://theuglytruth.files.wordpress.com/2013/06/palchild.jpg?w=150 150w, https://theuglytruth.files.wordpress.com/2013/06/palchild.jpg 460w" sizes="(max-width: 300px) 100vw, 300px" data-attachment-id="56542" data-permalink="https://theuglytruth.wordpress.com/palchild/" data-orig-file="https://theuglytruth.files.wordpress.com/2013/06/palchild.jpg" data-orig-size="460,276" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="palchild" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2013/06/palchild.jpg?w=300" data-large-file="https://theuglytruth.files.wordpress.com/2013/06/palchild.jpg?w=460" /></a></div></li><li><div id="media_image-73" class="widget widget_media_image"><h2 class="title">The Piper Report Archives</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="https://theuglytruth.wordpress.com/category/michael-collins-piper-archives/" class="" rel="" target=""><img class="image alignnone" src="https://theuglytruth.files.wordpress.com/2010/12/mcp1.jpg?w=620" alt="" width="300" height="300" /></a></div></li><li><div id="media_image-23" class="widget widget_media_image"><h2 class="title">The Ugly Truth Radio Program Archives</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="https://theuglytruth.wordpress.com/category/the-ugly-truth-podcast/" class="" rel="" target=""><img width="200" height="200" src="https://theuglytruth.files.wordpress.com/2012/02/onair.jpg?w=200" class="image wp-image-35314 alignnone attachment-200x200 size-200x200" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/02/onair.jpg?w=200 200w, https://theuglytruth.files.wordpress.com/2012/02/onair.jpg 400w, https://theuglytruth.files.wordpress.com/2012/02/onair.jpg?w=150 150w, https://theuglytruth.files.wordpress.com/2012/02/onair.jpg?w=300 300w" sizes="(max-width: 200px) 100vw, 200px" data-attachment-id="35314" data-permalink="https://theuglytruth.wordpress.com/onair/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/02/onair.jpg" data-orig-size="400,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="onair" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/02/onair.jpg?w=300" data-large-file="https://theuglytruth.files.wordpress.com/2012/02/onair.jpg?w=400" /></a></div></li><li><div id="media_image-74" class="widget widget_media_image"><h2 class="title">Ken O&#8217;Keefe</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.youtube.com/user/1worldcitizen?feature=watch" class="" rel="" target=""><img width="335" height="155" src="https://theuglytruth.files.wordpress.com/2014/03/ken1.jpg?w=335" class="image wp-image-64581 alignnone attachment-335x264 size-335x264" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2014/03/ken1.jpg?w=335 335w, https://theuglytruth.files.wordpress.com/2014/03/ken1.jpg?w=150 150w, https://theuglytruth.files.wordpress.com/2014/03/ken1.jpg?w=300 300w, https://theuglytruth.files.wordpress.com/2014/03/ken1.jpg 633w" sizes="(max-width: 335px) 100vw, 335px" data-attachment-id="64581" data-permalink="https://theuglytruth.wordpress.com/2014/03/14/ken-okeefe-us-congress-cia-serve-same-masters/ken1-2/" data-orig-file="https://theuglytruth.files.wordpress.com/2014/03/ken1.jpg" data-orig-size="633,292" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="Ken1" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2014/03/ken1.jpg?w=300" data-large-file="https://theuglytruth.files.wordpress.com/2014/03/ken1.jpg?w=620" /></a></div></li><li><div id="media_image-51" class="widget widget_media_image"><h2 class="title">Mark Dankof&#8217;s America&#8211;Broadcast Archives </h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="https://theuglytruth.wordpress.com/category/mark-dankofs-america-archives/" class="" rel="" target=""><img width="296" height="200" src="https://theuglytruth.files.wordpress.com/2012/08/md1.png?w=296" class="image wp-image-43280 alignnone attachment-300x200 size-300x200" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/08/md1.png?w=296 296w, https://theuglytruth.files.wordpress.com/2012/08/md1.png?w=150 150w, https://theuglytruth.files.wordpress.com/2012/08/md1.png?w=300 300w, https://theuglytruth.files.wordpress.com/2012/08/md1.png 340w" sizes="(max-width: 296px) 100vw, 296px" data-attachment-id="43280" data-permalink="https://theuglytruth.wordpress.com/2013/06/30/no-foreign-policy-benefit-for-americans/md1-2/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/08/md1.png" data-orig-size="340,230" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="MD1" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/08/md1.png?w=300" data-large-file="https://theuglytruth.files.wordpress.com/2012/08/md1.png?w=340" /></a></div></li><li><div id="media_image-35" class="widget widget_media_image"><h2 class="title">My Articles</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="https://theuglytruth.wordpress.com/category/my-articles/" class="" rel="" target=""><img class="image alignnone" src="https://theuglytruth.files.wordpress.com/2012/03/keyboard.jpg?w=500" alt="" width="200" height="200" /></a></div></li><li><div id="media_image-53" class="widget widget_media_image"><h2 class="title">Keith Johnson-Revolt of the Plebs Broadcast</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="https://theuglytruth.wordpress.com/category/revolt-of-the-plebs-broadcast-archives/" class="" rel="" target=""><img width="251" height="216" src="https://theuglytruth.files.wordpress.com/2012/08/rotp1.jpg" class="image wp-image-43300 alignnone attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/08/rotp1.jpg 251w, https://theuglytruth.files.wordpress.com/2012/08/rotp1.jpg?w=150&amp;h=129 150w" sizes="(max-width: 251px) 100vw, 251px" data-attachment-id="43300" data-permalink="https://theuglytruth.wordpress.com/2012/09/19/revolt-of-the-plebs-broadcast-sept-18-2012/rotp1/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/08/rotp1.jpg" data-orig-size="251,216" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="rotp1" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/08/rotp1.jpg?w=251" data-large-file="https://theuglytruth.files.wordpress.com/2012/08/rotp1.jpg?w=251" /></a></div></li><li><div id="media_image-54" class="widget widget_media_image"><h2 class="title">Mask of Zion Report Archives</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="https://theuglytruth.wordpress.com/category/mask-of-zion-broadcast-archives/" class="" rel="" target=""><img width="145" height="145" src="https://theuglytruth.files.wordpress.com/2012/11/ja1.jpg?w=145" class="image wp-image-47207 alignnone attachment-145x220 size-145x220" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/11/ja1.jpg?w=145 145w, https://theuglytruth.files.wordpress.com/2012/11/ja1.jpg?w=290 290w, https://theuglytruth.files.wordpress.com/2012/11/ja1.jpg?w=150 150w" sizes="(max-width: 145px) 100vw, 145px" data-attachment-id="47207" data-permalink="https://theuglytruth.wordpress.com/2012/11/22/mask-of-zion-report-nov-22-2012/ja1-2/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/11/ja1.jpg" data-orig-size="886,886" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="JA1" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/11/ja1.jpg?w=300" data-large-file="https://theuglytruth.files.wordpress.com/2012/11/ja1.jpg?w=620" /></a></div></li><li><div id="media_image-68" class="widget widget_media_image"><h2 class="title">On The Warning Track Broadcast</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="https://theuglytruth.wordpress.com/category/on-the-warning-track-broadcast/" class="" rel="" target=""><img width="200" height="200" src="https://theuglytruth.files.wordpress.com/2013/01/ronhall.jpg" class="image wp-image-49796 alignnone attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2013/01/ronhall.jpg 200w, https://theuglytruth.files.wordpress.com/2013/01/ronhall.jpg?w=150&amp;h=150 150w" sizes="(max-width: 200px) 100vw, 200px" data-attachment-id="49796" data-permalink="https://theuglytruth.wordpress.com/ronhall/" data-orig-file="https://theuglytruth.files.wordpress.com/2013/01/ronhall.jpg" data-orig-size="200,200" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="ronhall" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2013/01/ronhall.jpg?w=200" data-large-file="https://theuglytruth.files.wordpress.com/2013/01/ronhall.jpg?w=200" /></a></div></li><li><div id="media_image-55" class="widget widget_media_image"><h2 class="title">Sammi Ibrahem Broadcast Archives</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="https://theuglytruth.wordpress.com/category/sammi-ibrahem-archives/" class="" rel="" target=""><img class="image alignnone" src="https://theuglytruth.files.wordpress.com/2011/10/sammi.jpg?w=620" alt="" width="252" height="300" /></a></div></li><li><div id="media_image-60" class="widget widget_media_image"><h2 class="title">Max French&#8217;s The Victory Hour Archives</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="https://theuglytruth.wordpress.com/category/max-frenchs-the-victory-hour-archives/" class="" rel="" target=""><img width="250" height="150" src="https://theuglytruth.files.wordpress.com/2014/06/max.jpg?w=250" class="image wp-image-66701 alignnone attachment-250x300 size-250x300" alt="" style="max-width: 100%; height: auto;" title="Max French&#039;s The Victory Hour Archives" srcset="https://theuglytruth.files.wordpress.com/2014/06/max.jpg?w=250 250w, https://theuglytruth.files.wordpress.com/2014/06/max.jpg?w=500 500w, https://theuglytruth.files.wordpress.com/2014/06/max.jpg?w=150 150w, https://theuglytruth.files.wordpress.com/2014/06/max.jpg?w=300 300w" sizes="(max-width: 250px) 100vw, 250px" data-attachment-id="66701" data-permalink="https://theuglytruth.wordpress.com/2014/06/02/the-victory-hour-june-2-2014/max-3/" data-orig-file="https://theuglytruth.files.wordpress.com/2014/06/max.jpg" data-orig-size="960,576" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="max" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2014/06/max.jpg?w=300" data-large-file="https://theuglytruth.files.wordpress.com/2014/06/max.jpg?w=620" /></a></div></li><li><div id="media_image-71" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.amazon.com/Beauty-The-Beast-Israel-Without-Mascara/dp/B000T6LUUE/ref=aag_m_pw_dp?ie=UTF8&#038;m=AYSA0SIJ0WA8F" class="" rel="" target=""><img width="201" height="300" src="https://theuglytruth.files.wordpress.com/2013/05/beauty.jpg" class="image wp-image-55367 alignnone attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2013/05/beauty.jpg 201w, https://theuglytruth.files.wordpress.com/2013/05/beauty.jpg?w=101&amp;h=150 101w" sizes="(max-width: 201px) 100vw, 201px" data-attachment-id="55367" data-permalink="https://theuglytruth.wordpress.com/beauty/" data-orig-file="https://theuglytruth.files.wordpress.com/2013/05/beauty.jpg" data-orig-size="201,300" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="beauty" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2013/05/beauty.jpg?w=201" data-large-file="https://theuglytruth.files.wordpress.com/2013/05/beauty.jpg?w=201" /></a></div></li><li><div id="media_image-57" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.youtube.com/watch?feature=player_embedded&#038;v=O7XQtAw_-D0" class="" rel="" target=""><img width="153" height="153" src="https://theuglytruth.files.wordpress.com/2012/08/israeldid911.jpg?w=153" class="image wp-image-43476 alignnone attachment-200x200 size-200x200" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/08/israeldid911.jpg 153w, https://theuglytruth.files.wordpress.com/2012/08/israeldid911.jpg?w=150 150w" sizes="(max-width: 153px) 100vw, 153px" data-attachment-id="43476" data-permalink="https://theuglytruth.wordpress.com/israeldid911/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/08/israeldid911.jpg" data-orig-size="153,153" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="israeldid911" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/08/israeldid911.jpg?w=153" data-large-file="https://theuglytruth.files.wordpress.com/2012/08/israeldid911.jpg?w=153" /></a></div></li><li><div id="media_image-44" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="https://www.facebook.com/mark.glenn.9275" class="" rel="" target=""><img width="200" height="119" src="https://theuglytruth.files.wordpress.com/2016/02/facebook.jpg?w=200" class="image wp-image-111381 alignnone attachment-200x150 size-200x150" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2016/02/facebook.jpg?w=200 200w, https://theuglytruth.files.wordpress.com/2016/02/facebook.jpg?w=400 400w, https://theuglytruth.files.wordpress.com/2016/02/facebook.jpg?w=150 150w, https://theuglytruth.files.wordpress.com/2016/02/facebook.jpg?w=300 300w" sizes="(max-width: 200px) 100vw, 200px" data-attachment-id="111381" data-permalink="https://theuglytruth.wordpress.com/2016/02/01/ex-idf-intel-chief-facebook-is-greatest-threat-to-israel/facebook-2/" data-orig-file="https://theuglytruth.files.wordpress.com/2016/02/facebook.jpg" data-orig-size="960,573" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="FACEBOOK" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2016/02/facebook.jpg?w=300" data-large-file="https://theuglytruth.files.wordpress.com/2016/02/facebook.jpg?w=620" /></a></div></li><li><div id="media_image-67" class="widget widget_media_image"><h2 class="title">Snippets and Snappits</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://snippits-and-slappits.blogspot.ca/" class="" rel="" target=""><img width="102" height="116" src="https://theuglytruth.files.wordpress.com/2012/12/noor.png" class="image wp-image-47781 alignnone attachment-full size-full" alt="" style="max-width: 100%; height: auto;" title="Snippets and Snappits" data-attachment-id="47781" data-permalink="https://theuglytruth.wordpress.com/noor/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/12/noor.png" data-orig-size="102,116" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="noor" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/12/noor.png?w=102" data-large-file="https://theuglytruth.files.wordpress.com/2012/12/noor.png?w=102" /></a></div></li><li><div id="media_image-45" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://twitter.com/#!/TUTNetwork" class="" rel="" target=""><img width="154" height="150" src="https://theuglytruth.files.wordpress.com/2012/06/twitter.jpg?w=154" class="image wp-image-40495 alignnone attachment-200x150 size-200x150" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/06/twitter.jpg?w=154 154w, https://theuglytruth.files.wordpress.com/2012/06/twitter.jpg?w=150 150w, https://theuglytruth.files.wordpress.com/2012/06/twitter.jpg 300w" sizes="(max-width: 154px) 100vw, 154px" data-attachment-id="40495" data-permalink="https://theuglytruth.wordpress.com/twitter/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/06/twitter.jpg" data-orig-size="300,293" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="Twitter" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/06/twitter.jpg?w=300" data-large-file="https://theuglytruth.files.wordpress.com/2012/06/twitter.jpg?w=300" /></a></div></li><li><div id="media_image-65" class="widget widget_media_image"><h2 class="title">The Real Face of Judaism and Zionism</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.youtube.com/watch?v=AiijlI9bq4E&#038;feature=player_embedded" class="" rel="" target=""><img width="408" height="500" src="https://theuglytruth.files.wordpress.com/2012/10/boy1.jpg" class="image wp-image-45332 alignnone attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/10/boy1.jpg 408w, https://theuglytruth.files.wordpress.com/2012/10/boy1.jpg?w=122&amp;h=150 122w, https://theuglytruth.files.wordpress.com/2012/10/boy1.jpg?w=245&amp;h=300 245w" sizes="(max-width: 408px) 100vw, 408px" data-attachment-id="45332" data-permalink="https://theuglytruth.wordpress.com/boy1-3/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/10/boy1.jpg" data-orig-size="408,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;Canon EOS-1D Mark II&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1231169418&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;17&quot;,&quot;iso&quot;:&quot;640&quot;,&quot;shutter_speed&quot;:&quot;0.033333333333333&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="boy1" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/10/boy1.jpg?w=245" data-large-file="https://theuglytruth.files.wordpress.com/2012/10/boy1.jpg?w=408" /></a></div></li><li><div id="media_image-66" class="widget widget_media_image"><h2 class="title">Israhell on Earth</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.youtube.com/watch?v=Yt3d3Fmouh4&#038;feature=player_embedded" class="" rel="" target=""><img class="image alignnone" src="https://theuglytruth.files.wordpress.com/2009/03/pal1.jpg?w=620" alt="" width="350" height="273" /></a></div></li><li><div id="media_image-64" class="widget widget_media_image"><h2 class="title">the 5 dancing Israelis on 911</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.youtube.com/watch?v=rStJ5BgadPs&#038;feature=youtube_gdata_player" class="" rel="" target=""><img width="180" height="181" src="https://theuglytruth.files.wordpress.com/2012/09/dancing.jpg?w=180" class="image wp-image-44216 alignnone attachment-200x200 size-200x200" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/09/dancing.jpg 180w, https://theuglytruth.files.wordpress.com/2012/09/dancing.jpg?w=150 150w" sizes="(max-width: 180px) 100vw, 180px" data-attachment-id="44216" data-permalink="https://theuglytruth.wordpress.com/dancing/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/09/dancing.jpg" data-orig-size="180,181" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="dancing" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/09/dancing.jpg?w=180" data-large-file="https://theuglytruth.files.wordpress.com/2012/09/dancing.jpg?w=180" /></a></div></li><li><div id="media_image-47" class="widget widget_media_image"><h2 class="title">JEWISH FAMILY VALUES</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.youtube.com/watch?v=XXXoQKJVZgc" class="" rel="" target=""><img width="232" height="300" src="https://theuglytruth.files.wordpress.com/2012/07/goldsteinjpg.jpg?w=232" class="image wp-image-42279 alignnone attachment-300x300 size-300x300" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/07/goldsteinjpg.jpg?w=232 232w, https://theuglytruth.files.wordpress.com/2012/07/goldsteinjpg.jpg?w=116 116w, https://theuglytruth.files.wordpress.com/2012/07/goldsteinjpg.jpg 426w" sizes="(max-width: 232px) 100vw, 232px" data-attachment-id="42279" data-permalink="https://theuglytruth.wordpress.com/2014/01/31/sex-plague-the-normalization-of-deviance-and-depravity-by-lasha-darkmoon/goldsteinjpg/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/07/goldsteinjpg.jpg" data-orig-size="426,552" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="goldsteinJPG" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/07/goldsteinjpg.jpg?w=232" data-large-file="https://theuglytruth.files.wordpress.com/2012/07/goldsteinjpg.jpg?w=426" /></a></div></li><li><div id="media_image-48" class="widget widget_media_image"><h2 class="title">Judeo-Christianity</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.youtube.com/watch?v=GSrhJGGDqx0&#038;feature=player_embedded" class="" rel="" target=""><img width="300" height="200" src="https://theuglytruth.files.wordpress.com/2017/02/silverman.jpg?w=300" class="image wp-image-167275 alignnone attachment-300x300 size-300x300" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2017/02/silverman.jpg?w=300 300w, https://theuglytruth.files.wordpress.com/2017/02/silverman.jpg?w=150 150w, https://theuglytruth.files.wordpress.com/2017/02/silverman.jpg 552w" sizes="(max-width: 300px) 100vw, 300px" data-attachment-id="167275" data-permalink="https://theuglytruth.wordpress.com/2017/02/09/sen-schumer-attacks-trump-for-not-honoring-the-six-million-jews-murdered-by-the-nazis/silverman-4/" data-orig-file="https://theuglytruth.files.wordpress.com/2017/02/silverman.jpg" data-orig-size="552,368" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="silverman" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2017/02/silverman.jpg?w=300" data-large-file="https://theuglytruth.files.wordpress.com/2017/02/silverman.jpg?w=552" /></a></div></li><li><div id="media_image-62" class="widget widget_media_image"><h2 class="title">Mocking Jesus on Israeli TV</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.youtube.com/watch?v=JA6vRC1xW_c&#038;feature=player_detailpage" class="" rel="" target=""><img width="350" height="259" src="https://theuglytruth.files.wordpress.com/2012/09/jesus1.jpg" class="image wp-image-44174 alignnone attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/09/jesus1.jpg 350w, https://theuglytruth.files.wordpress.com/2012/09/jesus1.jpg?w=150&amp;h=111 150w, https://theuglytruth.files.wordpress.com/2012/09/jesus1.jpg?w=300&amp;h=222 300w" sizes="(max-width: 350px) 100vw, 350px" data-attachment-id="44174" data-permalink="https://theuglytruth.wordpress.com/2013/04/11/what-christians-dont-know-about-israel/jesus1-7/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/09/jesus1.jpg" data-orig-size="350,259" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="jesus1" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/09/jesus1.jpg?w=300" data-large-file="https://theuglytruth.files.wordpress.com/2012/09/jesus1.jpg?w=350" /></a></div></li><li><div id="media_image-63" class="widget widget_media_image"><h2 class="title">Jewish Ritual Infant Genital mutilation</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.youtube.com/watch?v=QpMdj7MfJSk&#038;feature=player_embedded" class="" rel="" target=""><img width="385" height="397" src="https://theuglytruth.files.wordpress.com/2012/09/mohel.jpg" class="image wp-image-44175 alignnone attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/09/mohel.jpg 385w, https://theuglytruth.files.wordpress.com/2012/09/mohel.jpg?w=145&amp;h=150 145w, https://theuglytruth.files.wordpress.com/2012/09/mohel.jpg?w=291&amp;h=300 291w" sizes="(max-width: 385px) 100vw, 385px" data-attachment-id="44175" data-permalink="https://theuglytruth.wordpress.com/mohel-2/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/09/mohel.jpg" data-orig-size="385,397" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="mohel" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/09/mohel.jpg?w=291" data-large-file="https://theuglytruth.files.wordpress.com/2012/09/mohel.jpg?w=385" /></a></div></li><li><div id="media_image-50" class="widget widget_media_image"><h2 class="title">God&#8217;s Chosen People</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.youtube.com/watch?v=eptPeSmA37U&#038;feature=player_embedded" class="" rel="" target=""><img width="208" height="200" src="https://theuglytruth.files.wordpress.com/2012/08/chosenpeople.jpg?w=208" class="image wp-image-43068 alignnone attachment-300x200 size-300x200" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/08/chosenpeople.jpg?w=208 208w, https://theuglytruth.files.wordpress.com/2012/08/chosenpeople.jpg?w=150 150w, https://theuglytruth.files.wordpress.com/2012/08/chosenpeople.jpg?w=300 300w, https://theuglytruth.files.wordpress.com/2012/08/chosenpeople.jpg 312w" sizes="(max-width: 208px) 100vw, 208px" data-attachment-id="43068" data-permalink="https://theuglytruth.wordpress.com/2014/01/29/yair-netanyahus-non-jewish-girlfriend-a-national-issue-shas-deri-says/chosenpeople/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/08/chosenpeople.jpg" data-orig-size="312,300" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="chosenpeople" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/08/chosenpeople.jpg?w=300" data-large-file="https://theuglytruth.files.wordpress.com/2012/08/chosenpeople.jpg?w=312" /></a></div></li><li><div id="media_image-61" class="widget widget_media_image"><h2 class="title">Examples of Jewish Hate Speech</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://whatreallyhappened.com/WRHARTICLES/palestinians.php" class="" rel="" target=""><img width="279" height="340" src="https://theuglytruth.files.wordpress.com/2012/09/hate1.jpg" class="image wp-image-44173 alignnone attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/09/hate1.jpg 279w, https://theuglytruth.files.wordpress.com/2012/09/hate1.jpg?w=123&amp;h=150 123w" sizes="(max-width: 279px) 100vw, 279px" data-attachment-id="44173" data-permalink="https://theuglytruth.wordpress.com/hate1/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/09/hate1.jpg" data-orig-size="279,340" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="hate1" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/09/hate1.jpg?w=246" data-large-file="https://theuglytruth.files.wordpress.com/2012/09/hate1.jpg?w=279" /></a></div></li><li><div id="text-3" class="widget widget_text">			<div class="textwidget"><a href="http://www.revolvermaps.com/?target=enlarge&amp;i=9pnrhw95nwq&amp;color=ff0000&amp;m=0"><img src="https://i0.wp.com/rj.revolvermaps.com/h/m/a/0/ff0000/128/0/9pnrhw95nwq.png" width="256" height="128" alt="Map" style="border:0;" /></a></div>
		</div></li><li><div id="media_image-59" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.youtube.com/watch?v=3aKj6uJ5Mt4&#038;feature=related" class="" rel="" target=""><img width="161" height="200" src="https://theuglytruth.files.wordpress.com/2015/12/911mossad.jpg?w=161" class="image wp-image-101863 alignnone attachment-200x200 size-200x200" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2015/12/911mossad.jpg?w=161 161w, https://theuglytruth.files.wordpress.com/2015/12/911mossad.jpg?w=322 322w, https://theuglytruth.files.wordpress.com/2015/12/911mossad.jpg?w=121 121w, https://theuglytruth.files.wordpress.com/2015/12/911mossad.jpg?w=242 242w" sizes="(max-width: 161px) 100vw, 161px" data-attachment-id="101863" data-permalink="https://theuglytruth.wordpress.com/911mossad-2/" data-orig-file="https://theuglytruth.files.wordpress.com/2015/12/911mossad.jpg" data-orig-size="500,621" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="911mossad" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2015/12/911mossad.jpg?w=242" data-large-file="https://theuglytruth.files.wordpress.com/2015/12/911mossad.jpg?w=500" /></a></div></li><li><div id="media_image-56" class="widget widget_media_image"><h2 class="title">911 Facts Unknown to Most People</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.youtube.com/watch?v=cvC1RNkmCWA&#038;feature=player_embedded" class="" rel="" target=""><img width="179" height="200" src="https://theuglytruth.files.wordpress.com/2012/08/911a.jpg?w=179" class="image wp-image-43446 alignnone attachment-200x200 size-200x200" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/08/911a.jpg?w=179 179w, https://theuglytruth.files.wordpress.com/2012/08/911a.jpg?w=358 358w, https://theuglytruth.files.wordpress.com/2012/08/911a.jpg?w=134 134w, https://theuglytruth.files.wordpress.com/2012/08/911a.jpg?w=268 268w" sizes="(max-width: 179px) 100vw, 179px" data-attachment-id="43446" data-permalink="https://theuglytruth.wordpress.com/2016/12/08/75-years-later-pearl-harbor-and-the-jewish-question/911a/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/08/911a.jpg" data-orig-size="492,550" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="911a" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/08/911a.jpg?w=268" data-large-file="https://theuglytruth.files.wordpress.com/2012/08/911a.jpg?w=492" /></a></div></li><li><div id="media_image-37" class="widget widget_media_image"><h2 class="title">Press TV/Russia Today Interviews</h2><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="https://theuglytruth.wordpress.com/category/television-interviews/" class="" rel="" target=""><img width="200" height="104" src="https://theuglytruth.files.wordpress.com/2016/07/mg.jpg?w=200" class="image wp-image-148343 alignnone attachment-200x230 size-200x230" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2016/07/mg.jpg?w=200 200w, https://theuglytruth.files.wordpress.com/2016/07/mg.jpg?w=400 400w, https://theuglytruth.files.wordpress.com/2016/07/mg.jpg?w=150 150w, https://theuglytruth.files.wordpress.com/2016/07/mg.jpg?w=300 300w" sizes="(max-width: 200px) 100vw, 200px" data-attachment-id="148343" data-permalink="https://theuglytruth.wordpress.com/2016/11/27/vote-recount-rooted-in-israels-desire-for-wwiii/mg-3/" data-orig-file="https://theuglytruth.files.wordpress.com/2016/07/mg.jpg" data-orig-size="584,304" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="MG" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2016/07/mg.jpg?w=300" data-large-file="https://theuglytruth.files.wordpress.com/2016/07/mg.jpg?w=584" /></a></div></li><li><div id="media_image-16" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="https://theuglytruth.wordpress.com/2012/01/29/please-consider-donating-to-the-ugly-truth-13/" class="" rel="" target=""><img class="image alignnone" src="https://theuglytruth.files.wordpress.com/2011/04/censorship1.jpg?w=80" alt="" width="200" height="250" /></a></div></li><li><div id="media_image-14" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://blog.thespiritualun.org/" class="" rel="" target=""><img width="200" height="132" src="https://theuglytruth.files.wordpress.com/2012/05/tsun2.png?w=200" class="image wp-image-39462 alignnone attachment-200x200 size-200x200" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/05/tsun2.png?w=200 200w, https://theuglytruth.files.wordpress.com/2012/05/tsun2.png?w=400 400w, https://theuglytruth.files.wordpress.com/2012/05/tsun2.png?w=150 150w, https://theuglytruth.files.wordpress.com/2012/05/tsun2.png?w=300 300w" sizes="(max-width: 200px) 100vw, 200px" data-attachment-id="39462" data-permalink="https://theuglytruth.wordpress.com/tsun2/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/05/tsun2.png" data-orig-size="434,286" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="tsun2" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/05/tsun2.png?w=300" data-large-file="https://theuglytruth.files.wordpress.com/2012/05/tsun2.png?w=434" /></a></div></li><li><div id="media_image-49" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.citizensamericaparty.org/" class="" rel="" target=""><img width="182" height="222" src="https://theuglytruth.files.wordpress.com/2012/07/gw.jpg?w=182" class="image wp-image-42643 alignnone attachment-200x222 size-200x222" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/07/gw.jpg 182w, https://theuglytruth.files.wordpress.com/2012/07/gw.jpg?w=123 123w" sizes="(max-width: 182px) 100vw, 182px" data-attachment-id="42643" data-permalink="https://theuglytruth.wordpress.com/gw/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/07/gw.jpg" data-orig-size="182,222" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="gw" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/07/gw.jpg?w=182" data-large-file="https://theuglytruth.files.wordpress.com/2012/07/gw.jpg?w=182" /></a></div></li><li><div id="media_image-34" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.gilad.co.uk/writings" class="" rel="" target=""><img width="163" height="250" src="https://theuglytruth.files.wordpress.com/2012/03/gilad.jpg?w=163" class="image wp-image-36670 alignnone attachment-200x250 size-200x250" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/03/gilad.jpg?w=163 163w, https://theuglytruth.files.wordpress.com/2012/03/gilad.jpg?w=98 98w, https://theuglytruth.files.wordpress.com/2012/03/gilad.jpg 195w" sizes="(max-width: 163px) 100vw, 163px" data-attachment-id="36670" data-permalink="https://theuglytruth.wordpress.com/2012/05/04/the-dysfunctional-ideology-of-jewishness-review-of-gilad-atzmons-book-the-wandering-who-a-study-of-jewish-identity-politics/gilad/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/03/gilad.jpg" data-orig-size="195,300" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="gilad" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/03/gilad.jpg?w=195" data-large-file="https://theuglytruth.files.wordpress.com/2012/03/gilad.jpg?w=195" /></a></div></li><li><div id="media_image-30" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.habilian.ir/en/" class="" rel="" target=""><img width="131" height="200" src="https://theuglytruth.files.wordpress.com/2012/04/habilian2.jpg?w=131" class="image wp-image-38428 alignnone attachment-200x200 size-200x200" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/04/habilian2.jpg?w=131 131w, https://theuglytruth.files.wordpress.com/2012/04/habilian2.jpg?w=98 98w, https://theuglytruth.files.wordpress.com/2012/04/habilian2.jpg 197w" sizes="(max-width: 131px) 100vw, 131px" data-attachment-id="38428" data-permalink="https://theuglytruth.wordpress.com/habilian2/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/04/habilian2.jpg" data-orig-size="197,301" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="habilian2" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/04/habilian2.jpg?w=196" data-large-file="https://theuglytruth.files.wordpress.com/2012/04/habilian2.jpg?w=197" /></a></div></li><li><div id="media_image-40" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.shoah.org.uk/" class="" rel="" target=""><img width="200" height="52" src="https://theuglytruth.files.wordpress.com/2012/04/shoah1.jpg?w=200" class="image wp-image-38765 alignnone attachment-200x100 size-200x100" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/04/shoah1.jpg?w=200 200w, https://theuglytruth.files.wordpress.com/2012/04/shoah1.jpg?w=150 150w, https://theuglytruth.files.wordpress.com/2012/04/shoah1.jpg?w=300 300w, https://theuglytruth.files.wordpress.com/2012/04/shoah1.jpg 384w" sizes="(max-width: 200px) 100vw, 200px" data-attachment-id="38765" data-permalink="https://theuglytruth.wordpress.com/shoah1/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/04/shoah1.jpg" data-orig-size="384,100" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="shoah1" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/04/shoah1.jpg?w=300" data-large-file="https://theuglytruth.files.wordpress.com/2012/04/shoah1.jpg?w=384" /></a></div></li><li><div id="media_image-27" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.presstv.com" class="" rel="" target=""><img width="106" height="60" src="https://theuglytruth.files.wordpress.com/2013/03/ptv.jpg?w=106" class="image wp-image-52352 alignnone attachment-200x60 size-200x60" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2013/03/ptv.jpg?w=106 106w, https://theuglytruth.files.wordpress.com/2013/03/ptv.jpg?w=212 212w, https://theuglytruth.files.wordpress.com/2013/03/ptv.jpg?w=150 150w" sizes="(max-width: 106px) 100vw, 106px" data-attachment-id="52352" data-permalink="https://theuglytruth.wordpress.com/2013/03/13/eu-unable-to-justify-its-anti-press-tv-move/ptv-4/" data-orig-file="https://theuglytruth.files.wordpress.com/2013/03/ptv.jpg" data-orig-size="650,367" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="ptv" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2013/03/ptv.jpg?w=300" data-large-file="https://theuglytruth.files.wordpress.com/2013/03/ptv.jpg?w=620" /></a></div></li><li><div id="media_image-26" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.rt.com" class="" rel="" target=""><img class="image alignnone" src="https://theuglytruth.files.wordpress.com/2012/02/rt.jpg?w=620" alt="" width="200" height="250" /></a></div></li><li><div id="media_image-36" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://hispantv.ir/" class="" rel="" target=""><img width="200" height="62" src="https://theuglytruth.files.wordpress.com/2012/03/hispantv_logo.jpg?w=200" class="image wp-image-37546 alignnone attachment-200x100 size-200x100" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/03/hispantv_logo.jpg?w=200 200w, https://theuglytruth.files.wordpress.com/2012/03/hispantv_logo.jpg?w=150 150w, https://theuglytruth.files.wordpress.com/2012/03/hispantv_logo.jpg 210w" sizes="(max-width: 200px) 100vw, 200px" data-attachment-id="37546" data-permalink="https://theuglytruth.wordpress.com/hispantv_logo/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/03/hispantv_logo.jpg" data-orig-size="210,65" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="hispantv_logo" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/03/hispantv_logo.jpg?w=210" data-large-file="https://theuglytruth.files.wordpress.com/2012/03/hispantv_logo.jpg?w=210" /></a></div></li><li><div id="media_image-39" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://syrianfreepress.wordpress.com" class="" rel="" target=""><img width="200" height="57" src="https://theuglytruth.files.wordpress.com/2012/04/sfp1.jpg?w=200" class="image wp-image-38680 alignnone attachment-200x100 size-200x100" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/04/sfp1.jpg?w=200 200w, https://theuglytruth.files.wordpress.com/2012/04/sfp1.jpg?w=400 400w, https://theuglytruth.files.wordpress.com/2012/04/sfp1.jpg?w=150 150w, https://theuglytruth.files.wordpress.com/2012/04/sfp1.jpg?w=300 300w" sizes="(max-width: 200px) 100vw, 200px" data-attachment-id="38680" data-permalink="https://theuglytruth.wordpress.com/sfp1/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/04/sfp1.jpg" data-orig-size="713,204" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="SFP1" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/04/sfp1.jpg?w=300" data-large-file="https://theuglytruth.files.wordpress.com/2012/04/sfp1.jpg?w=620" /></a></div></li><li><div id="media_image-29" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><img width="129" height="100" src="https://theuglytruth.files.wordpress.com/2016/09/iraq.jpg?w=129" class="image wp-image-156807 alignnone attachment-200x100 size-200x100" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2016/09/iraq.jpg?w=129 129w, https://theuglytruth.files.wordpress.com/2016/09/iraq.jpg?w=258 258w, https://theuglytruth.files.wordpress.com/2016/09/iraq.jpg?w=150 150w" sizes="(max-width: 129px) 100vw, 129px" data-attachment-id="156807" data-permalink="https://theuglytruth.wordpress.com/iraq-8/" data-orig-file="https://theuglytruth.files.wordpress.com/2016/09/iraq.jpg" data-orig-size="375,291" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="iraq" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2016/09/iraq.jpg?w=300" data-large-file="https://theuglytruth.files.wordpress.com/2016/09/iraq.jpg?w=375" /></div></li><li><div id="media_image-18" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><img class="image alignnone" src="https://theuglytruth.files.wordpress.com/2011/04/z11.jpg?w=46" alt="" width="200" height="250" /></div></li><li><div id="media_image-20" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><img class="image alignnone" src="https://theuglytruth.files.wordpress.com/2011/03/pic1.jpg?w=39" alt="" width="200" height="250" /></div></li><li><div id="media_image-21" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.youtube.com/user/ravenise004?feature=results_main" class="" rel="" target=""><img class="image alignnone" src="https://theuglytruth.files.wordpress.com/2011/01/nwo3.gif?w=38" alt="" width="200" height="250" /></a></div></li><li><div id="media_image-28" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><img width="200" height="134" src="https://theuglytruth.files.wordpress.com/2012/02/tank.jpg?w=200" class="image wp-image-36093 alignnone attachment-200x200 size-200x200" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2012/02/tank.jpg?w=200 200w, https://theuglytruth.files.wordpress.com/2012/02/tank.jpg?w=150 150w, https://theuglytruth.files.wordpress.com/2012/02/tank.jpg 274w" sizes="(max-width: 200px) 100vw, 200px" data-attachment-id="36093" data-permalink="https://theuglytruth.wordpress.com/tank-2/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/02/tank.jpg" data-orig-size="274,184" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="tank" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/02/tank.jpg?w=274" data-large-file="https://theuglytruth.files.wordpress.com/2012/02/tank.jpg?w=274" /></div></li><li><div id="media_image-46" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.maskofzion.com" class="" rel="" target=""><img width="200" height="200" src="https://theuglytruth.files.wordpress.com/2012/06/moz2.gif?w=200" class="image wp-image-40942 alignnone attachment-200x200 size-200x200" alt="" style="max-width: 100%; height: auto;" data-attachment-id="40942" data-permalink="https://theuglytruth.wordpress.com/moz2/" data-orig-file="https://theuglytruth.files.wordpress.com/2012/06/moz2.gif" data-orig-size="2083,2083" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="moz2" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2012/06/moz2.gif?w=300" data-large-file="https://theuglytruth.files.wordpress.com/2012/06/moz2.gif?w=620" /></a></div></li><li><div id="media_image-52" class="widget widget_media_image"><style>.widget.widget_media_image { overflow: hidden; }.widget.widget_media_image img { height: auto; max-width: 100%; }</style><a href="http://www.palestinenature.org/" class="" rel="" target=""><img width="291" height="141" src="https://theuglytruth.files.wordpress.com/2016/04/palestine1.jpg?w=291" class="image wp-image-128646 alignnone attachment-291x173 size-291x173" alt="" style="max-width: 100%; height: auto;" srcset="https://theuglytruth.files.wordpress.com/2016/04/palestine1.jpg?w=291 291w, https://theuglytruth.files.wordpress.com/2016/04/palestine1.jpg?w=582 582w, https://theuglytruth.files.wordpress.com/2016/04/palestine1.jpg?w=150 150w, https://theuglytruth.files.wordpress.com/2016/04/palestine1.jpg?w=300 300w" sizes="(max-width: 291px) 100vw, 291px" data-attachment-id="128646" data-permalink="https://theuglytruth.wordpress.com/2016/04/14/3000-nights-and-stories-from-behind-israeli-prison-bars/palestine-14/" data-orig-file="https://theuglytruth.files.wordpress.com/2016/04/palestine1.jpg" data-orig-size="599,290" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="palestine" data-image-description="" data-medium-file="https://theuglytruth.files.wordpress.com/2016/04/palestine1.jpg?w=300" data-large-file="https://theuglytruth.files.wordpress.com/2016/04/palestine1.jpg?w=599" /></a></div></li><li><div id="linkcat-1356" class="widget widget_links"><h2 class="title">Blogroll</h2>
	<ul class='xoxo blogroll'>
<li><a href="http://www.ascertainthetruth.com/att/">Ascertain The Truth</a></li>
<li><a href="http://currentissues.tv">Current Issues</a></li>
<li><a href="http://informationclearinghouse.info">Information Clearing House</a></li>
<li><a href="http://www.islamophobiatoday.com/">Islamophobia Today</a></li>
<li><a href="http://kenokeefe.wordpress.com">Ken O&#039;Keefe</a></li>
<li><a href="http://www.blogtalkradio.com/tutradionetwork">The Ugly Truth Internet Radio Program</a></li>
<li><a href="http://WhatReallyHappened.com">What Really Happened</a></li>

	</ul>
</div></li>
<li><div id="archives-5" class="widget widget_archive"><h2 class="title">Archives</h2>		<ul>
			<li><a href='https://theuglytruth.wordpress.com/2017/11/'>November 2017</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2017/10/'>October 2017</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2017/09/'>September 2017</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2017/08/'>August 2017</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2017/07/'>July 2017</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2017/06/'>June 2017</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2017/05/'>May 2017</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2017/04/'>April 2017</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2017/03/'>March 2017</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2017/02/'>February 2017</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2017/01/'>January 2017</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2016/12/'>December 2016</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2016/11/'>November 2016</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2016/10/'>October 2016</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2016/09/'>September 2016</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2016/08/'>August 2016</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2016/07/'>July 2016</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2016/06/'>June 2016</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2016/05/'>May 2016</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2016/04/'>April 2016</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2016/03/'>March 2016</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2016/02/'>February 2016</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2016/01/'>January 2016</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2015/12/'>December 2015</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2015/11/'>November 2015</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2015/10/'>October 2015</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2015/09/'>September 2015</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2015/08/'>August 2015</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2015/07/'>July 2015</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2015/06/'>June 2015</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2015/05/'>May 2015</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2015/04/'>April 2015</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2015/03/'>March 2015</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2015/02/'>February 2015</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2015/01/'>January 2015</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2014/12/'>December 2014</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2014/11/'>November 2014</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2014/10/'>October 2014</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2014/09/'>September 2014</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2014/08/'>August 2014</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2014/07/'>July 2014</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2014/06/'>June 2014</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2014/05/'>May 2014</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2014/04/'>April 2014</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2014/03/'>March 2014</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2014/02/'>February 2014</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2014/01/'>January 2014</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2013/12/'>December 2013</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2013/11/'>November 2013</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2013/10/'>October 2013</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2013/09/'>September 2013</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2013/08/'>August 2013</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2013/07/'>July 2013</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2013/06/'>June 2013</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2013/05/'>May 2013</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2013/04/'>April 2013</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2013/03/'>March 2013</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2013/02/'>February 2013</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2013/01/'>January 2013</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2012/12/'>December 2012</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2012/11/'>November 2012</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2012/10/'>October 2012</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2012/09/'>September 2012</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2012/08/'>August 2012</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2012/07/'>July 2012</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2012/06/'>June 2012</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2012/05/'>May 2012</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2012/04/'>April 2012</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2012/03/'>March 2012</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2012/02/'>February 2012</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2012/01/'>January 2012</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2011/12/'>December 2011</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2011/11/'>November 2011</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2011/10/'>October 2011</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2011/09/'>September 2011</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2011/08/'>August 2011</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2011/07/'>July 2011</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2011/06/'>June 2011</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2011/05/'>May 2011</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2011/04/'>April 2011</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2011/03/'>March 2011</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2011/02/'>February 2011</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2011/01/'>January 2011</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2010/12/'>December 2010</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2010/11/'>November 2010</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2010/10/'>October 2010</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2010/09/'>September 2010</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2010/08/'>August 2010</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2010/07/'>July 2010</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2010/06/'>June 2010</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2010/05/'>May 2010</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2010/04/'>April 2010</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2010/03/'>March 2010</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2010/02/'>February 2010</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2010/01/'>January 2010</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2009/12/'>December 2009</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2009/11/'>November 2009</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2009/10/'>October 2009</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2009/09/'>September 2009</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2009/08/'>August 2009</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2009/07/'>July 2009</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2009/06/'>June 2009</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2009/05/'>May 2009</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2009/04/'>April 2009</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2009/03/'>March 2009</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2009/02/'>February 2009</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2009/01/'>January 2009</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2008/12/'>December 2008</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2008/11/'>November 2008</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2008/10/'>October 2008</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2008/09/'>September 2008</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2008/08/'>August 2008</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2008/07/'>July 2008</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2008/06/'>June 2008</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2008/05/'>May 2008</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2008/04/'>April 2008</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2008/03/'>March 2008</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2008/02/'>February 2008</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2008/01/'>January 2008</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2007/12/'>December 2007</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2007/11/'>November 2007</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2007/10/'>October 2007</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2007/08/'>August 2007</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2007/06/'>June 2007</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2007/05/'>May 2007</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2007/04/'>April 2007</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2007/03/'>March 2007</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2007/02/'>February 2007</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2007/01/'>January 2007</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2006/12/'>December 2006</a></li>
	<li><a href='https://theuglytruth.wordpress.com/2006/11/'>November 2006</a></li>
		</ul>
		</div></li>		</ul>

	</div>
	<!-- /sidebar 2nd container -->

	</div>
	<!-- /sidebar 1st container -->

</div>
<!-- /sidebar -->

		
	</div>
	<!-- /side wrap -->

	</div>
	<!-- /mid column wrap -->

</div>
<!-- /main wrapper -->

<div class="clearcontent"></div>


<div id="footer">

	<p>
		
			</p>
</div>
<!-- /footer -->

</div>
<!-- /page -->

</div>

</div>
<!-- /page wrappers -->

<!--  -->
	<div style="display:none">
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/theuglytruth.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/theuglytruth.wordpress.com\/wp-login.php?action=logout&_wpnonce=f1f34894d2","homeURL":"https:\/\/theuglytruth.wordpress.com\/","postID":"183281","gravDefault":"mystery","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1479964158j'></script>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="529252" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://theuglytruth.wordpress.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="The Ugly Truth" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="9f87ea561c" /><input type="hidden" name="_wp_http_referer" value="/2017/11/17/a-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president/" />		</form>

		<div class="arrow"></div>
	</div>
<script type='text/javascript' charset='UTF-8' id='polldaddyRatings'><!--//--><![CDATA[//><!--
PDRTJS_settings_2452776_post_183281={"id":2452776,"unique_id":"wp-post-183281","title":"A%20Group%20of%20Democrats%20led%20by%20Jewish%20congressman%20Steve%20Cohen%20Just%20Officially%20Moved%20to%20Impeach%20Donald%20Trump%20as%26nbsp%3BPresident","permalink":"https:\/\/theuglytruth.wordpress.com\/2017\/11\/17\/a-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president\/","item_id":"_post_183281"}; if ( typeof PDRTJS_RATING !== 'undefined' ){if ( typeof PDRTJS_2452776_post_183281 == 'undefined' ){PDRTJS_2452776_post_183281 = new PDRTJS_RATING( PDRTJS_settings_2452776_post_183281 );}}
//--><!]]></script><script type='text/javascript' charset='UTF-8' src='https://polldaddy.com/js/rating/rating.js'></script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/theuglytruth.wordpress.com\/2017\/11\/17\/a-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president\/":183281};
	</script>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
			<div id="sharing_email" style="display: none;">
		<form action="/2017/11/17/a-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script> document.getElementById('jetpack-source_f_name').value = ''; </script>
			<div class="recaptcha" id="sharing_recaptcha"></div><input type="hidden" name="recaptcha_public_key" id="recaptcha_public_key" value="6LcYW8MSAAAAADBAuEH9yaPcF7lWh11Iq62ZKtoo" />
			<img style="float: right; display: none" class="loading" src="https://s2.wp.com/wp-content/mu-plugins/post-flair/sharing/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-google-plus-1' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-tumblr' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
		});
		</script>
							<script type="text/javascript">
				jQuery(document).on('ready', function(){
					jQuery('body').on('click', 'a.share-pinterest', function(e){
						e.preventDefault();
						// Load Pinterest Bookmarklet code
						var s = document.createElement("script");
						s.type = "text/javascript";
						s.src = window.location.protocol + "//assets.pinterest.com/js/pinmarklet.js?r=" + ( Math.random() * 99999999 );
						var x = document.getElementsByTagName("script")[0];
						x.parentNode.insertBefore(s, x);
						// Trigger Stats
						var s = document.createElement("script");
						s.type = "text/javascript";
						s.src = this + ( this.toString().indexOf( '?' ) ? '&' : '?' ) + 'js_only=1';
						var x = document.getElementsByTagName("script")[0];
						x.parentNode.insertBefore(s, x);
					});
				});
			</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-linkedin' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
		});
		</script>
		<link rel='stylesheet' id='all-css-0-3' href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1481571546h' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"529252","siteName":"The Ugly Truth","siteURL":"http:\/\/theuglytruth.wordpress.com","icon":"<img alt='' src='https:\/\/s1.wp.com\/i\/logo\/wpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/fusion","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/theuglytruth.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Ftheuglytruth.wordpress.com%2F2017%2F11%2F17%2Fa-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president%2F","themeURL":"","xhrURL":"https:\/\/theuglytruth.wordpress.com\/wp-admin\/admin-ajax.php","nonce":"f0a16d591f","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"cfbacadfde\" \/>","referer":"https:\/\/theuglytruth.wordpress.com\/2017\/11\/17\/a-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president\/","canFollow":"1","feedID":"31081","statusMessage":"","customizeLink":"https:\/\/theuglytruth.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Ftheuglytruth.wordpress.com%2F2017%2F11%2F17%2Fa-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president%2F","postID":"183281","shortlink":"https:\/\/wp.me\/p2dGk-LG9","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/theuglytruth.wordpress.com\/183281","statsLink":"https:\/\/wordpress.com\/stats\/post\/183281\/theuglytruth.wordpress.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Fusion","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 5,827 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/theuglytruth.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Ftheuglytruth.wordpress.com%2F2017%2F11%2F17%2Fa-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president%2F\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/theuglytruth.wordpress.com\/wp-admin\/admin-ajax.php","nonce":"8264271c86","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/theuglytruth.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Ftheuglytruth.wordpress.com%2F2017%2F11%2F17%2Fa-group-of-democrats-led-by-jewish-congressman-steve-cohen-just-officially-moved-to-impeach-donald-trump-as-president%2F","blog_id":"529252","local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=529252&v=wpcom&tz=-8&user_id=0&subd=theuglytruth","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJyVT9FuwjAM/CFSg1g38YD4FJSlpjhNnGAnwP5+QVoRD6jSns463/nOcMvGJS7IBbzCgFdymO+d1xW8rGI1OdSRWCHQhAqXihXPloeAsiC2QyQ231YgWi0obTLpiiI0tCNP7p8Xilg36ZLJFUr8MD2nWU3sQn2Et281E7/jfftOfv6ge1W9yXJWUlUM4LHk1svMxFK/iTRiMdtuDceWDKckcUGfkxZzCpYE9GyFeJyxmQ5xv+nXu+3XR//Z+1/ipq1k'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20170206#ver=20170206' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
<script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'529252','blog_tz':'-8','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'529252','v':'wpcom','tz':'-8','user_id':'0','post':'183281','subd':'theuglytruth'}]);
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1hV3xrb2xUT3JBbjREZWgvK29XZW1dcW9pNnd3Rkx0fHowaGR0UVFtVEgydVprSi4wWVNNK2MvSV9pL29WbVtIXSZqWGlLJmJ2cTh+P0hBOFFkOCY3LFguP0EvdH5tZjFrVTlJbz1qQzVoTzg/Wndfc2JpVDdYWXFoeU1TL3Q9K2xuS3lBNmVIP2EzN08/XXhnXXxkXzZzUjFkTlhkVl9PNWxPbXwza2lqVVB2Mlp8MVZvUU9KKz1ZLkxFeF9hRmx3cz9BWGZ1LjdIVSZVaXFGMWVWLlk4SDM0QXZabkhdOWduSnhdWDEyM0NUPWFDc1FZVS9iRnFuMGpFZVVjZkFJSERnTyZoOVovdk1tZDRrV0hST1JlLzY2WlZHdjhHbkIv'}]);
_stq.push([ 'clickTrackerInit', '529252', '183281' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>